打开主菜单
Toolbox from GIMP 2.6

GIMP提供了一个综合的工具箱,以便于快速执行基本任务。工具箱可充分定制,这意味着您可以添加或移除任何工具。您只要到窗口 > 可停靠对话框 > 工具选择要添加或移除的工具即可。

默认情况下,并不是所有的工具都会被显示出来,比如GEGL操作和颜色工具就被省略了。通过工具菜单,你可以打开所有工具。想切换到工具箱窗口,你可以使用Ctrl+B组合键。当然了,这里说的都是默认情况下的快捷键,你可以通过编辑 > 快捷键进行调节。

目录

工具编辑

一般情况下,下列工具会出现在工具箱中:

图标 名称 快捷键 简介
选择工具
  矩形选择工具 R 选择矩形或正方形区域。
  椭圆选择工具 E 选择椭圆或圆形区域。
  自由选择工具 F 又称“套索工具”,用于选择任意形状的区域。
  模糊选择工具 U 又称“魔棒工具”,根据颜色选择一片连续的区域。
  按颜色选择工具 Shift + O 选择所有颜色相似的区域。
  剪刀选择工具 I 又称“磁性套索工具”,根据边缘选择形状。
  前景选择工具 选择包含前景对象的区域。
笔刷工具
  油漆桶填充工具 Shift + B 用一种颜色或团填充选中的区域。
  混合工具 L 又称“渐变工具”,用颜色渐变填充选中的区域。
  铅笔工具 N 用于做硬边缘的绘画。
  画笔工具 P 用于做边缘平滑的绘画。
  橡皮工具 Shift + E 用于擦除图层上的图案。
  喷枪工具 A 用于做带有不同压力的绘图。
  墨水工具 K 用于绘制有书法风格、无锯齿的线条。
  克隆工具 C 又称“仿制图章工具”,用于将一幅图片中的图案复制到另一幅图中。
  复原工具 H 修复图像的不规则。
  透明克隆工具 用于从应用透视变换后的图片中复制内容。
  模糊/锐化工具 Shift + U 模糊或锐化图像。
  涂抹工具 S 从“推”的方向扩散图案。
  减淡/加深工具 Shift + D 亮化或暗化图像中的阴影、中间色调和亮点。
变换工具
  Move M Moves layers and selections.
  Align Q Align or arrange layers and/or other objects.
  Crop Shift + C Crops or clips the image.
  Rotate Shift + R Rotates the active layer, selection or path.
  Scale Shift + T Scales the active layer, selection or path.
  Shear Shift + S Shifts part of the image to some direction.
  Perspective Shift + P Changes the perspective of the active layer, selection or path.
  Flip Shift + F Flips layers and selections.
Other tools
  Path B Allows selecting and modifying paths.
  Colour Picker O Selects the colour of any image opened on your screen.
  Magnify (Zoom) Z Alters the zoom level of the image.
  Measure Shift + M Shows distances and angles.
  Text M Places text into your image.

There are also some other tools, hidden by default. These tools need to be accessed from the "Tools" menu, or by showing them in toolbox (Windows > Dockable Dialogues > Tools).

Icon Name Shortcut Description
Colour tools
  Colour Balance (none) Modifies the colour balance of current selection or layer.
  Hue-Saturation (none) Adjusts hue, saturation and lightness.
  Colourize (none) Renders current selection or layer into a grey scale image seen through coloured glass.
  Brightness-Contrast (none) Adjusts brightness and contrast.
  Threshold (none) Transforms the current layer or selection into a black and white image.
  Levels (none) Changes the intensity range of the active layer or selection in every channel.
  Curves (none) Changes the colour, brightness, contrast or transparency of the active layer or path.
  Posterize (none) Reduces the number of colours.
  Desaturate (none) Converts all colour to the corresponding shades of grey.
Other tools
  GEGL operation (none) Executes a GEGL operation.

Tool options编辑

By default, activating any tool, will have the effect of showing its options under the toolbox. Each tool has its own set of settings and any changes to them are kept through the current session. There are also four buttons under any options.

  •   Save options to... - save options of the current tool
  •   Restore options from... - restore options from saved file
  •   Delete saved options... - delete saved options
  •   Reset to default values - reset the settings to default values.

You can hide them by clicking on the arrow next to the tool name and deselecting Show Button Bar. You can also access these from the same menu under Tool Options Menu.

Colour, Indicator and Active Image area编辑

 
Colour, Indicator and Active Image areas respectively.

Below the toolbox can be placed these three areas. This is set in "Edit > Preferences > Toolbox" and any of the three can be hid there.

Colour area编辑

Shows current foreground and background colour. Clicking on either will bring up the colour editor dialogue.

Clicking on the symbol in the lower left corner resets the colour to their defaults. The D key has the same effect.

Clicking on the symbol in the upper right corner swaps the foreground and background colours. The X key has the same effect.

Indicator area编辑

Shows currently selected brush, pattern or gradient. Clicking on any of these allows you to change it.

Active Image area编辑

Displays a thumbnail of the active image. Clicking on it will bring the Images dialogue up, allowing you the select an image.